import re
regex = re.compile(r"(?i)\bw(?:eigh)?t\b.{1,25}?\b(?<!\d/)(\d+(?:\.\d+)?)(?!/?\d)\s*(\w+)", flags=re.MULTILINE)
test_str = ("Weight Measured: 80.7 kg 11/27/1900 24:59:00\n"
"Pulse 64 \\F\\ Temp 37.3?C (99.1 ?F) \\F\\ Wt 101.2 kg (223 lb)\n"
"Weight as of 11/11/1900 72.2 kg (159 lb 1.6 oz)\n"
"Resp. rate 16, height 177.8 cm (5' 10\"), weight 84.7 kg (186 lb|\n"
"11.2 oz)\n"
"And one extra weight example 100lbs")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")