package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+`)
var str = `טקסט שיש בו פה ושם משפרים. כמו 21 ואפילו 45.
כל הזכויות שמורות לתחומים.קום, 2018
`
var substitution = "#\0#"
fmt.Println(re.ReplaceAllString(str, substitution))
}