$re = '/\d+/';
$str = 'טקסט שיש בו פה ושם משפרים. כמו 21 ואפילו 45.
כל הזכויות שמורות לתחומים.קום, 2018
';
$subst = "#\0#";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;