const regex = /\d+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+', 'g')
const str = `טקסט שיש בו פה ושם משפרים. כמו 21 ואפילו 45.
כל הזכויות שמורות לתחומים.קום, 2018
`;
const subst = `#\0#`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);