package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^;]+;[^;]+;)[^;]+$`)
var str = `текст1;текст2;текст3
$1 это то что тебе нужно`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}