$re = '/^([^;]+;[^;]+;)[^;]+$/m';
$str = 'текст1;текст2;текст3
$1 это то что тебе нужно';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);