re = /^([^;]+;[^;]+;)[^;]+$/m
str = 'текст1;текст2;текст3
$1 это то что тебе нужно'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end