using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*(?=.*\/shop\/(dogs|cats))((\/[^\/]+){3}$))";
string input = @"https://www.zooplus.co.uk/shop/cats/wet_dog_food";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}