$re = '/(.*(?=.*\/shop\/(dogs|cats))((\/[^\/]+){3}$))/';
$str = 'https://www.zooplus.co.uk/shop/cats/wet_dog_food';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);