re = /(.*(?=.*\/shop\/(dogs|cats))((\/[^\/]+){3}$))/
str = 'https://www.zooplus.co.uk/shop/cats/wet_dog_food'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end