using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+@\w+\.[a-zA-Z]{2,6}";
string input = @"My email is a8gd0ddf7hdh@gmail.com.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}