package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+@\w+\.[a-zA-Z]{2,6}`)
var str = `My email is a8gd0ddf7hdh@gmail.com.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}