$re = '/\w+@\w+\.[a-zA-Z]{2,6}/';
$str = 'My email is a8gd0ddf7hdh@gmail.com.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);