#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\+?[\d]?\s*\(?\d{3}\)?[\s\.-]?\d{3}[\s\.-]?\d{4}"
Local $sString = "Task: Return only the residents of Spencerport, NY who have phone numbers listed. Include the name, address and phone number of the individual(s)." & @CRLF & _
"----------------------------------------------------------------" & @CRLF & _
"Public Records and Phone Records Listings" & @CRLF & _
"" & @CRLF & _
"DEFRANK, EDMUND" & @CRLF & _
"823 WASHINGTON ST, SPENCERPORT, NY 14559-9703." & @CRLF & _
"Phone Number 585-352-9218" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"ODELL, E" & @CRLF & _
"BRIGHTON, NY 12970." & @CRLF & _
"Phone Number 585-327-3686" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"DEFRANCO, FRANK" & @CRLF & _
"6 REX LN, SPENCERPORT, NY 14559-9700" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"DR. OBRECT, MICHAEL" & @CRLF & _
"200 RED CREEK DR, HENRIETTA, NY 14467" & @CRLF & _
"Phone Number +1 (585) 334-0352" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"FRANCIS, PAUL" & @CRLF & _
"37 TROTTER DR, HENRIETTA, NY 14467-9769." & @CRLF & _
"Phone Number 585-334-7733" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"CARLSON, BRITA" & @CRLF & _
"1 BURKE LN #D, SPENCERPORT, NY 14559-1546." & @CRLF & _
"Phone Number +1 (585) 3529383" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"EDWARDS, SUSAN" & @CRLF & _
"4621 W RIDGE RD, SPENCERPORT, NY 14559-1552." & @CRLF & _
"Phone Number " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"CARLSON, JEFF" & @CRLF & _
"21 NEVINS RD, HENRIETTA, NY 14467-9307." & @CRLF & _
"Phone Number 585-359-9545" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"FRANCIS, RICHARD" & @CRLF & _
"13 LINDA LN, SPENCERPORT, NY 14559-1613. " & @CRLF & _
"Phone Number" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"DEFREZE, GREGORY" & @CRLF & _
"10 BIG RIDGE RD, SPENCERPORT, NY 14559-1219." & @CRLF & _
"Phone Number 5853520978" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"ENGLEHARDT, HERBERT" & @CRLF & _
"75 TOTTENHAM RD, BRIGHTON, NY 14610-2244." & @CRLF & _
"Phone Number 585-482-2955" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"CARTER, GARY" & @CRLF & _
"204 PINE HILL RD, SPENCERPORT, NY 14559-1010." & @CRLF & _
"Phone Number (585)352-8826" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"DEGEN, MARK" & @CRLF & _
"27 COBRA DR, HENRIETTA, NY 14467-9512." & @CRLF & _
"Phone Number 585-321-3524" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"DEGENNARO, VICTOR" & @CRLF & _
"537 WASHINGTON ST, SPENCERPORT, NY 14559-9539." & @CRLF & _
"Phone Number +1 (585) 352-3824" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"FRANCIS, THOMAS" & @CRLF & _
"4812 LYELL RD, SPENCERPORT, NY 14559-2014." & @CRLF & _
"Phone Number 585-352-4758" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"CARTER, LINDA" & @CRLF & _
"50 JORDACHE LN, SPENCERPORT, NY 14559-2059." & @CRLF & _
"Phone Number 585-352-4913"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")