# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\+?[\d]?\s*\(?\d{3}\)?[\s\.-]?\d{3}[\s\.-]?\d{4}"
test_str = ("Task: Return only the residents of Spencerport, NY who have phone numbers listed. Include the name, address and phone number of the individual(s).\n"
"----------------------------------------------------------------\n"
"Public Records and Phone Records Listings\n\n"
"DEFRANK, EDMUND\n"
"823 WASHINGTON ST, SPENCERPORT, NY 14559-9703.\n"
"Phone Number 585-352-9218\n\n\n"
"ODELL, E\n"
"BRIGHTON, NY 12970.\n"
"Phone Number 585-327-3686\n\n\n"
"DEFRANCO, FRANK\n"
"6 REX LN, SPENCERPORT, NY 14559-9700\n\n\n"
"DR. OBRECT, MICHAEL\n"
"200 RED CREEK DR, HENRIETTA, NY 14467\n"
"Phone Number +1 (585) 334-0352\n\n\n"
"FRANCIS, PAUL\n"
"37 TROTTER DR, HENRIETTA, NY 14467-9769.\n"
"Phone Number 585-334-7733\n\n\n"
"CARLSON, BRITA\n"
"1 BURKE LN #D, SPENCERPORT, NY 14559-1546.\n"
"Phone Number +1 (585) 3529383\n\n\n"
"EDWARDS, SUSAN\n"
"4621 W RIDGE RD, SPENCERPORT, NY 14559-1552.\n"
"Phone Number \n\n\n"
"CARLSON, JEFF\n"
"21 NEVINS RD, HENRIETTA, NY 14467-9307.\n"
"Phone Number 585-359-9545\n\n\n"
"FRANCIS, RICHARD\n"
"13 LINDA LN, SPENCERPORT, NY 14559-1613. \n"
"Phone Number\n\n\n"
"DEFREZE, GREGORY\n"
"10 BIG RIDGE RD, SPENCERPORT, NY 14559-1219.\n"
"Phone Number 5853520978\n\n\n"
"ENGLEHARDT, HERBERT\n"
"75 TOTTENHAM RD, BRIGHTON, NY 14610-2244.\n"
"Phone Number 585-482-2955\n\n\n"
"CARTER, GARY\n"
"204 PINE HILL RD, SPENCERPORT, NY 14559-1010.\n"
"Phone Number (585)352-8826\n\n\n"
"DEGEN, MARK\n"
"27 COBRA DR, HENRIETTA, NY 14467-9512.\n"
"Phone Number 585-321-3524\n\n\n"
"DEGENNARO, VICTOR\n"
"537 WASHINGTON ST, SPENCERPORT, NY 14559-9539.\n"
"Phone Number +1 (585) 352-3824\n\n\n"
"FRANCIS, THOMAS\n"
"4812 LYELL RD, SPENCERPORT, NY 14559-2014.\n"
"Phone Number 585-352-4758\n\n\n"
"CARTER, LINDA\n"
"50 JORDACHE LN, SPENCERPORT, NY 14559-2059.\n"
"Phone Number 585-352-4913")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.