import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\+?[\\d]?\\s*\\(?\\d{3}\\)?[\\s\\.-]?\\d{3}[\\s\\.-]?\\d{4}";
final String string = "Task: Return only the residents of Spencerport, NY who have phone numbers listed. Include the name, address and phone number of the individual(s).\n"
+ "----------------------------------------------------------------\n"
+ "Public Records and Phone Records Listings\n\n"
+ "DEFRANK, EDMUND\n"
+ "823 WASHINGTON ST, SPENCERPORT, NY 14559-9703.\n"
+ "Phone Number 585-352-9218\n\n\n"
+ "ODELL, E\n"
+ "BRIGHTON, NY 12970.\n"
+ "Phone Number 585-327-3686\n\n\n"
+ "DEFRANCO, FRANK\n"
+ "6 REX LN, SPENCERPORT, NY 14559-9700\n\n\n"
+ "DR. OBRECT, MICHAEL\n"
+ "200 RED CREEK DR, HENRIETTA, NY 14467\n"
+ "Phone Number +1 (585) 334-0352\n\n\n"
+ "FRANCIS, PAUL\n"
+ "37 TROTTER DR, HENRIETTA, NY 14467-9769.\n"
+ "Phone Number 585-334-7733\n\n\n"
+ "CARLSON, BRITA\n"
+ "1 BURKE LN #D, SPENCERPORT, NY 14559-1546.\n"
+ "Phone Number +1 (585) 3529383\n\n\n"
+ "EDWARDS, SUSAN\n"
+ "4621 W RIDGE RD, SPENCERPORT, NY 14559-1552.\n"
+ "Phone Number \n\n\n"
+ "CARLSON, JEFF\n"
+ "21 NEVINS RD, HENRIETTA, NY 14467-9307.\n"
+ "Phone Number 585-359-9545\n\n\n"
+ "FRANCIS, RICHARD\n"
+ "13 LINDA LN, SPENCERPORT, NY 14559-1613. \n"
+ "Phone Number\n\n\n"
+ "DEFREZE, GREGORY\n"
+ "10 BIG RIDGE RD, SPENCERPORT, NY 14559-1219.\n"
+ "Phone Number 5853520978\n\n\n"
+ "ENGLEHARDT, HERBERT\n"
+ "75 TOTTENHAM RD, BRIGHTON, NY 14610-2244.\n"
+ "Phone Number 585-482-2955\n\n\n"
+ "CARTER, GARY\n"
+ "204 PINE HILL RD, SPENCERPORT, NY 14559-1010.\n"
+ "Phone Number (585)352-8826\n\n\n"
+ "DEGEN, MARK\n"
+ "27 COBRA DR, HENRIETTA, NY 14467-9512.\n"
+ "Phone Number 585-321-3524\n\n\n"
+ "DEGENNARO, VICTOR\n"
+ "537 WASHINGTON ST, SPENCERPORT, NY 14559-9539.\n"
+ "Phone Number +1 (585) 352-3824\n\n\n"
+ "FRANCIS, THOMAS\n"
+ "4812 LYELL RD, SPENCERPORT, NY 14559-2014.\n"
+ "Phone Number 585-352-4758\n\n\n"
+ "CARTER, LINDA\n"
+ "50 JORDACHE LN, SPENCERPORT, NY 14559-2059.\n"
+ "Phone Number 585-352-4913";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}