#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\bTODO|\!(?=\[[^\]]*\]\(\))|\[(?=[^\]]*\]\(\)))[:;.,]?\d*($|\[[^\]]*\]|.*?(?=\]\(\))|\s.*$|\(.*$)"
Local $sString = "hello world" & @CRLF & _
"" & @CRLF & _
"TODO yes please" & @CRLF & _
"" & @CRLF & _
"TODO: hello wordl" & @CRLF & _
"" & @CRLF & _
"!: hello world" & @CRLF & _
"" & @CRLF & _
"TODO: ![image mix-up test]()" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"![]()" & @CRLF & _
"" & @CRLF & _
"![yes this is it]()" & @CRLF & _
"" & @CRLF & _
"THis is [a link]() " & @CRLF & _
"" & @CRLF & _
"TODO: okay" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")