re = /(\bTODO|\!(?=\[[^\]]*\]\(\))|\[(?=[^\]]*\]\(\)))[:;.,]?\d*($|\[[^\]]*\]|.*?(?=\]\(\))|\s.*$|\(.*$)/m
str = 'hello world
TODO yes please
TODO: hello wordl
!: hello world
TODO: ![image mix-up test]()
![]()
![yes this is it]()
THis is [a link]()
TODO: okay
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end