const regex = /(\bTODO|\!(?=\[[^\]]*\]\(\))|\[(?=[^\]]*\]\(\)))[:;.,]?\d*($|\[[^\]]*\]|.*?(?=\]\(\))|\s.*$|\(.*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\bTODO|\\!(?=\\[[^\\]]*\\]\\(\\))|\\[(?=[^\\]]*\\]\\(\\)))[:;.,]?\\d*($|\\[[^\\]]*\\]|.*?(?=\\]\\(\\))|\\s.*$|\\(.*$)', 'gm')
const str = `hello world
TODO yes please
TODO: hello wordl
!: hello world
TODO: ![image mix-up test]()
![]()
![yes this is it]()
THis is [a link]()
TODO: okay
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}