using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<pos[^<>]*?>\s*(.*?)<\/pos>";
string input = @"<pos w=\""12\""> good</pos>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}