$re = '/<pos[^<>]*?>\s*(.*?)<\/pos>/';
$str = '<pos w=\\"12\\"> good</pos>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);