package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<pos[^<>]*?>\s*(.*?)<\/pos>`)
var str = `<pos w=\"12\"> good</pos>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}