import re
regex = re.compile(r"(?P<ip_class>A{1,4}) (?P<ip>[a-f,A-Z,0-9,:,\.]+) (?P<ttl>\d+)(?P<comma_space>, )?", flags=re.MULTILINE)
test_str = "A 10.95.151.82 5, A 10.95.151.81 5, AAAA fd88:3be1:fee4:8c5d::2c 5, AAAA fd88:3be1:fee4:8c5c::2a 5"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")