import Foundation
let pattern = #"(?P<ip_class>A{1,4}) (?P<ip>[a-f,A-Z,0-9,:,\.]+) (?P<ttl>\d+)(?P<comma_space>, )?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"A 10.95.151.82 5, A 10.95.151.81 5, AAAA fd88:3be1:fee4:8c5d::2c 5, AAAA fd88:3be1:fee4:8c5c::2a 5"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)