// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<ip_class>A{1,4}) (?P<ip>[a-f,A-Z,0-9,:,\.]+) (?P<ttl>\d+)(?P<comma_space>, )?").unwrap();
let string = "A 10.95.151.82 5, A 10.95.151.81 5, AAAA fd88:3be1:fee4:8c5d::2c 5, AAAA fd88:3be1:fee4:8c5c::2a 5";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}