use strict;
my $str = '#### should MATCH all of these:
http://www.host.com
https://www.host.com
https://www.host.com
http://host.com
http://www.host.tv
https://www.host.live
host.com
www.host.com
http://sub-services.host.com
sub-services.host.com
g.host.com
gg.host.com
gggg.host.com
something-services.host.com
#### should NOT MATCH all of these:
http://www.something.com
http://www.host-something.com
http://www.host.something-com
http://www.hosts.com
https://www.host
https://www.host.live.com
http://.host.com
http://www.host.tv.com
something.com
.host.com
www.com
';
my $regex = qr/^(https?\:\/\/|[a-zA-Z0-9]?)([a-zA-Z0-9\-]+\.host\.[a-zA-Z0-9]+$|host\.[a-zA-Z0-9]+$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}