re = /^(https?\:\/\/|[a-zA-Z0-9]?)([a-zA-Z0-9\-]+\.host\.[a-zA-Z0-9]+$|host\.[a-zA-Z0-9]+$)/m
str = '#### should MATCH all of these:
http://www.host.com
https://www.host.com
https://www.host.com
http://host.com
http://www.host.tv
https://www.host.live
host.com
www.host.com
http://sub-services.host.com
sub-services.host.com
g.host.com
gg.host.com
gggg.host.com
something-services.host.com
#### should NOT MATCH all of these:
http://www.something.com
http://www.host-something.com
http://www.host.something-com
http://www.hosts.com
https://www.host
https://www.host.live.com
http://.host.com
http://www.host.tv.com
something.com
.host.com
www.com
'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end