$re = '/^(\w{3}\s\d{3}).*?(\w)\s+\w$/';
$str = 'CSC 101 Intro to Computing A R';
$subst = "\1 \2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;