import re
regex = re.compile(r"^(\w{3}\s\d{3}).*?(\w)\s+\w$")
test_str = "CSC 101 Intro to Computing A R"
subst = "\\1 \\2"
result = regex.sub(subst, test_str)
if result:
print(result)