re = /^(\w{3}\s\d{3}).*?(\w)\s+\w$/
str = 'CSC 101 Intro to Computing A R'
subst = '\\1 \\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result