using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\w, ()'._-]";
string input = @"aBcd🍇🍊, (test foo) '.txt
aBcd🍇🍊, (test foo) ' - Co.py.txt";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}