$re = '/[^\w, ()\'._-]/';
$str = 'aBcd🍇🍊, (test foo) \'.txt
aBcd🍇🍊, (test foo) \' - Co.py.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);