package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\w, ()'._-]`)
var str = `aBcd🍇🍊, (test foo) '.txt
aBcd🍇🍊, (test foo) ' - Co.py.txt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}