$re = '/\b(\w{3,}(?:-(?:\w{3,}))*)-(\w{2})-game-play\b/m';
$str = 'cricket-ck-game-play
hand-ball-hb-game-play
volley-ball-vb-game-play
soccer-sc-game-play
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);