re = /\b(\w{3,}(?:-(?:\w{3,}))*)-(\w{2})-game-play\b/m
str = 'cricket-ck-game-play
hand-ball-hb-game-play
volley-ball-vb-game-play
soccer-sc-game-play
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end