const regex = /^\d{1,3}(\\d{3})*,\d{2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{1,3}(\\\\d{3})*,\\d{2}$', 'gm')
const str = `10,00
10\\ddd,00
10\\ddd\\ddd,00
1000,00
123456,00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}