$re = '/^\d{1,3}(\\\\d{3})*,\d{2}$/m';
$str = '10,00
10\\ddd,00
10\\ddd\\ddd,00
1000,00
123456,00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);