re = /^\d{1,3}(\\d{3})*,\d{2}$/m
str = '10,00
10\\ddd,00
10\\ddd\\ddd,00
1000,00
123456,00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end