$re = '/https?:\/\/embed\.([^\/]*)\.com\/?\?id=([0-9]+)/';
$str = 'https://embed.thatsite.com?id=212
https://embed.thatsite.com/?id=132';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);