re = /https?:\/\/embed\.([^\/]*)\.com\/?\?id=([0-9]+)/
str = 'https://embed.thatsite.com?id=212
https://embed.thatsite.com/?id=132'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end