// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"https?:\/\/embed\.([^\/]*)\.com\/?\?id=([0-9]+)").unwrap();
let string = "https://embed.thatsite.com?id=212
https://embed.thatsite.com/?id=132";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}