#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[A-Za-z].*\R\K(?:[1-9]\R)+(?=0$)"
Local $sString = "ABC" & @CRLF & _
"5" & @CRLF & _
"0" & @CRLF & _
"gdfgdfg" & @CRLF & _
"-----------" & @CRLF & _
"GHN" & @CRLF & _
"0" & @CRLF & _
"ffffffff" & @CRLF & _
"fffff" & @CRLF & _
"ffff" & @CRLF & _
"trte" & @CRLF & _
"-------------" & @CRLF & _
"H" & @CRLF & _
"1" & @CRLF & _
"0" & @CRLF & _
"----------------"
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)