use strict;
my $str = 'ABC
5
0
gdfgdfg
-----------
GHN
0
ffffffff
fffff
ffff
trte
-------------
H
1
0
----------------';
my $regex = qr/^[A-Za-z].*\R\K(?:[1-9]\R)+(?=0$)/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";