package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^q\s]\s*)(t)`)
var str = `q t qt qqqtqt qt q tt q t t qq t qt q t`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}