const regex = /([^q\s]\s*)(t)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^q\\s]\\s*)(t)', 'gm')
const str = `q t qt qqqtqt qt q tt q t t qq t qt q t`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}