$re = '/\b(?!zz)\w+?zz\w+\b(?<!zz)/m';
$str = 'lorem ipsum buzz mezzo mix zztop but this is all azzazza azzzzza';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);