#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\/\*([^*]|[\r\n]|(\*+([^*\/]|[\r\n])))*\*+\/)|(\/\/.*)"
Local $sString = "<?" & @CRLF & _
"/* This is a comment */" & @CRLF & _
"" & @CRLF & _
"cout << "Hello World"; // prints Hello World" & @CRLF & _
"" & @CRLF & _
"/*" & @CRLF & _
" * C++ comments can also" & @CRLF & _
" */" & @CRLF & _
"" & @CRLF & _
"cout << "Hello World"; " & @CRLF & _
"" & @CRLF & _
"/* Comment out printing of Hello World:" & @CRLF & _
"" & @CRLF & _
"cout << "Hello World"; // prints Hello World" & @CRLF & _
"" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"echo "//This line was not a Comment, but ... ";" & @CRLF & _
"echo "http://stackoverflow.com";" & @CRLF & _
"echo 'http://stackoverflow.com/you can not match this line';" & @CRLF & _
"array = ['//', 'no, you can not match this line!!']" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")