// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\/\*([^*]|[\r\n]|(\*+([^*\/]|[\r\n])))*\*+\/)|(\/\/.*)").unwrap();
let string = "<?
/* This is a comment */
cout << \"Hello World\"; // prints Hello World
/*
* C++ comments can also
*/
cout << \"Hello World\";
/* Comment out printing of Hello World:
cout << \"Hello World\"; // prints Hello World
*/
echo \"//This line was not a Comment, but ... \";
echo \"http://stackoverflow.com\";
echo 'http://stackoverflow.com/you can not match this line';
array = ['//', 'no, you can not match this line!!']
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}