using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\bis:(Foo|Bar)\b.*";
string input = @"""is:Baz is:Foo FooBar"" # Captures ""Foo""
""is:Foo FooBar is:Bar"" # Captures ""Bar""
""is:Bar FooBar FooBaz Baz"" # Captures ""Bar""
""FooBar is:Bar FooBaz"" # Captures ""Bar""
""FooBar is:Xyzzy is:Foo"" # Captures ""Foo
""is:Baz FooBar is:Foo"" # Captures ""Foo""
""FooBar is:Foo is:Xyzzy"" # No capture";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}