// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*\bis:(Foo|Bar)\b.*").unwrap();
let string = "\"is:Baz is:Foo FooBar\" # Captures \"Foo\"
\"is:Foo FooBar is:Bar\" # Captures \"Bar\"
\"is:Bar FooBar FooBaz Baz\" # Captures \"Bar\"
\"FooBar is:Bar FooBaz\" # Captures \"Bar\"
\"FooBar is:Xyzzy is:Foo\" # Captures \"Foo
\"is:Baz FooBar is:Foo\" # Captures \"Foo\"
\"FooBar is:Foo is:Xyzzy\" # No capture";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}